Brought to you by Barnacle Bill's Marine Supply. (856) 785 9455

Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
FloraBama57

Registered:
Posts: 21
Reply with quote  #1 
2011 Etec 300 that's been having some issues with trim. Trim goes up fine but then can't get the engine down without using the manual release. I've been asking around and most people seem to think its the relay assembly (little black box) under the cowling which is part number 0586767 and costs about $120. Does that sound correct? 
__________________
O Taste and see that The Lord is good. Blessed is the man that trusteth in Him. Psalm 34:8
ETECowner

Registered:
Posts: 17
Reply with quote  #2 
I would verify the wiring before buying a relay.  I had a similar problem on my 150.  It ended up being a recessed pin on a connector.
FloraBama57

Registered:
Posts: 21
Reply with quote  #3 
Wiring to the switches on controls and engine?
__________________
O Taste and see that The Lord is good. Blessed is the man that trusteth in Him. Psalm 34:8
Nordmann

Registered:
Posts: 1,518
Reply with quote  #4 
Swap blue and green heavy wires from relay to T/T motor, if it now trims down only, relay is cactus.
__________________
Nordmann.

Sign seen in a dentist's waiting room:
There is nothing the dentist can do, that the patient won't do!
finnaddict98

Registered:
Posts: 90
Reply with quote  #5 
Before anything else, make a jumper for the limiter switch, found on the port side of the motor near the front, its a grey assembly---unhook it, insert the "jumper wire" into the holes and see if that fixes your issue, if it does, then you've isolated your issue to the trim limiter switch....not recommended, but I know guys who've just left the jumper in there over replacing the switch. I replaced MY switch!
FloraBama57

Registered:
Posts: 21
Reply with quote  #6 
Just an update. I removed the cowling today and found the relay box (about the size of a match box) on the starboard side of the engine. I whacked on it a couple times with a screwdriver handle and my down trim came back and it worked with both the toggle switch on the helm controls and the one on the engine switch. I'm assuming that means I've got a bad relay. Does that sound right to you guys?
__________________
O Taste and see that The Lord is good. Blessed is the man that trusteth in Him. Psalm 34:8
engelmyr

Registered:
Posts: 21
Reply with quote  #7 
Hi, I have 2011 250 and experienced a similar problem. Would happen only a couple times a summer. Dealers replaced relay twice over two summers. Turned out the original and first replacement were defective.
FloraBama57

Registered:
Posts: 21
Reply with quote  #8 
The relay doesn't look that difficult to replace. Has anyone ever done it themselves. The only thing I saw on mine was that it looks like it's been replaced before. Two wires going down to the trim assembly under the engine were butt joined to the relay. The other wires have a wire connector clip. I'll have to cut the butt joined wires and reconnect them.
__________________
O Taste and see that The Lord is good. Blessed is the man that trusteth in Him. Psalm 34:8
kitjam

Registered:
Posts: 1
Reply with quote  #9 
I have a similar issue with one of my 150's, port engine will go up but not down from helm controls but works with switch on the engine. I've swapped every switch connection to the diode assemble and problem remains with port engine only and only trimming down wont work. There is a wrinkle, it does work when the engine is right at the bottom, i.e. in the trim range of motion (when the trim motor runs slower for fine tuning trim when running). So, it looks like the issue is under the cowling, I'm assuming at or near the relay? Any thoughts from anyone??
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Disclaimer: Activities and modifications described or displayed on this message board and it's pages may be potentially dangerous. E-TEC Owners Group along with Barnacle Bills Marine does not endorse or make any claims to their safety or performance. Be sure a trained E-TEC service technician performs all your service work.