Brought to you by Barnacle Bill's Marine Supply. (856) 785 9455

Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
charles_wahlin

Avatar / Picture

Registered:
Posts: 5
Reply with quote  #1 
Hi
Yesterday after about 10 minutes ride in 15 knots with my Etec 90 hp in some rough weather, boat slow down and I could not reach higher rpm than about 1700rpm. No warnings of temp or oil problems. We finally reached harbour and the day after I tested to throttle with no gear and same problem. I had my first 3 year service this spring and replaced the electrical fuel pump. Can it be a broken fuel pump again?
Regards
Charles Wahlin, currently in Kalmar on the swedish west coast.
Etec 90 model. E90DSLAAA
SERIAL. 535676

__________________
Best Regards
Charles Wahlin
Etec 90, E90DSLAAA, 5353676
charles_wahlin

Avatar / Picture

Registered:
Posts: 5
Reply with quote  #2 
Quote:
Originally Posted by charles_wahlin
Hi
Yesterday after about 10 minutes ride in 15 knots with my Etec 90 hp in some rough weather, boat slow down and I could not reach higher rpm than about 1700rpm. No warnings of temp or oil problems. We finally reached harbour and the day after I tested to throttle with no gear and same problem. I had my first 3 year service this spring and replaced the electrical fuel pump. Can it be a broken fuel pump again?
Regards
Charles Wahlin, currently in Kalmar on the swedish west coast.
Etec 90 model. E90DSLAAA
SERIAL. 535676

__________________
Best Regards
Charles Wahlin
Etec 90, E90DSLAAA, 5353676
WernerF

Avatar / Picture

Registered:
Posts: 88
Reply with quote  #3 
1700 rpm sounds suspicious. Could be the neutral switch.

Check if engine rpm rises a little (typically from 600 rpm to 700 rpm) when you shift from neutral into gear. If it doesn't the neutal switch is probably bad. Then the EMM "thinks" to be in neutral and limits rpm to about 1800.
PhilH12

Registered:
Posts: 3,504
Reply with quote  #4 
There should be a 'Rev Limit' when actually running in Neutral, [the day after I tested to throttle with no gear] so that isn't really a good test.  Meanwhile, it could be the switch, as WernerF says - It "thinks" it's in Neutral.

Phil

__________________
Always check the Easy Stuff First!
20' Weeres fishing pontoon
90 HP E-Tec E90DPLSUM  05184332
Lake Tawakoni, TX - Catfish Capital of Texas
charles_wahlin

Avatar / Picture

Registered:
Posts: 5
Reply with quote  #5 
Tnx Phil and WernerF for your answers.

I will do the test shifting from neutral to gear and inspect if rpm rises from 600 to 700 or not. If I have this error, will it also be seen as a trouble code when running diagnostics? I will go back to Gothenburg to the swedish west coast today and let my marine workshop look at my problem. Do you guys know if a neutral switch error is easy to fix and if it will be covered by product guarantee?

BR
Charles

__________________
Best Regards
Charles Wahlin
Etec 90, E90DSLAAA, 5353676
WernerF

Avatar / Picture

Registered:
Posts: 88
Reply with quote  #6 
No error code. The EMM cannot detect being in neutral correctly or falsely since there is no other information about that. It must rely on the signal of the neutral switch.

To replace the switch the lower motor covers must be removed (actually the starbord cover, but they are mounted together). Be careful not to damage them because they are absurdly overprized. When the cover is off the switch is easily accessible.
trevshar

Registered:
Posts: 4
Reply with quote  #7 
Yep Sounds like Neutral switch ....easy to replace .... refrain from using any sort of spray lubricant around switch 

charles_wahlin

Avatar / Picture

Registered:
Posts: 5
Reply with quote  #8 
Tnx for the tip about neutral switch but I don't think it is a problem any longer. When I pulled up my boat from the water it actually ran fine when gear was engaged.I was fooled by the rev limitation in neutral. I investigated fuel system and found leftovers from paper towel in fuel tank. This was stuck in the fuel outlet from the tank. I think this was the root cause of my problem. When boat is in water again I will do a longer test run. Do you think anything can get broken if fuel line was almost blocked when I ran engine while going back home in bad weather. Anyway I removed paper from the tank and hopefully problem is solved.
Br
Charles

__________________
Best Regards
Charles Wahlin
Etec 90, E90DSLAAA, 5353676
trevshar

Registered:
Posts: 4
Reply with quote  #9 
Good luck Charles please let me know if it fixes the problem
charles_wahlin

Avatar / Picture

Registered:
Posts: 5
Reply with quote  #10 
Tnx everybody. Problem is solved. All was due to the levtovers in fuel tank. Nothing serms to be broken.
__________________
Best Regards
Charles Wahlin
Etec 90, E90DSLAAA, 5353676
PhilH12

Registered:
Posts: 3,504
Reply with quote  #11 
We always love to hear Happy Endings!  Not sure how you got paper towels in there, but as I often say to myself "Guess I won't do that again".  [wink]

Happy boating!

Phil

__________________
Always check the Easy Stuff First!
20' Weeres fishing pontoon
90 HP E-Tec E90DPLSUM  05184332
Lake Tawakoni, TX - Catfish Capital of Texas
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Disclaimer: Activities and modifications described or displayed on this message board and it's pages may be potentially dangerous. E-TEC Owners Group along with Barnacle Bills Marine does not endorse or make any claims to their safety or performance. Be sure a trained E-TEC service technician performs all your service work.