Brought to you by Barnacle Bill's Marine Supply. (856) 785 9455

Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
abvenier

Registered:
Posts: 5
Reply with quote  #1 
I have had this issue for a few years. keep chasing it. I have a 2007 etec 250hp. When i start the motor with the engine cover on the check engine light comes on and the alarm sounds. when i take the cover off the light will go off eventually. if i try to plug it in to the diagnostic, (the light usually is off by then) it says no code was thrown. Once the engine light goes off and you go to put the cover back on the light will go on and the alarm sound again. i have tested this several times and seems to come on only when the cover is on. once underway however it will usually clear after a few alarm cycles. i cant figure out if its maybe an airflow issue, bad sensor maybe. Anyone have any advice. Thanks
__________________
Arthur Venier
mead

Registered:
Posts: 771
Reply with quote  #2 
You need to have Evinrude diagnostics report the specific fault code which triggers the check engine light. There are many codes that trigger this light so the issue needs to be narrowed down to aid your troubleshooting.
abvenier

Registered:
Posts: 5
Reply with quote  #3 
Cannot seem to get the code to show up. Was just seeing if anyone had a similar issue.
__________________
Arthur Venier
seahorse

Avatar / Picture

Moderator
Registered:
Posts: 8,785
Reply with quote  #4 
Does the CHECK ENGINE come on when the cover is just placed over the motor, or only after it is latched down?
__________________
...possessing more tools than talent !


My sarcasm and my sincerity sound surprisingly similar !
abvenier

Registered:
Posts: 5
Reply with quote  #5 
When places over the motor. Does not have to be latched down
__________________
Arthur Venier
abvenier

Registered:
Posts: 5
Reply with quote  #6 
I have actually narrowed it down to a loose/chafed Wire somewhere near the blue capacitor. When putting the engine cover on it rubs against the black cover that covers all the wires and capacitor. Whatever it is when its moved it sets off check engine and alarm. Just have to try and find which wore it is.
__________________
Arthur Venier
rickmcd53

Registered:
Posts: 2,493
Reply with quote  #7 
I don't have service manuals with me at the moment but the wires from the EMM to the system check lights are all tan with a stripe, one is plain tan.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Disclaimer: Activities and modifications described or displayed on this message board and it's pages may be potentially dangerous. E-TEC Owners Group along with Barnacle Bills Marine does not endorse or make any claims to their safety or performance. Be sure a trained E-TEC service technician performs all your service work.