Brought to you by Barnacle Bill's Marine Supply. (856) 785 9455

Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
Nifty1

Registered:
Posts: 13
Reply with quote  #1 
Engine Serial Number05179699  
Engine Model NumberE90DPLSUM 
Hi all,  Finally launched my project boat on Saturday. re etec 2006 90 with 304 hrs which was dealer serviced when mounted 11 mths ago and run out of water, regularly since. Starts first kick, followed by 1 beep and idles smoothly. Control gear selector/throttle lever moves easily/smoothly and correctly to fwd, neutral & reverse
The Problem,, There was no throttle rpm increase past 6 knt idle, when I pushed the lever forward on reaching unrestricted water. It ran smoothly & I was not aware of any warning beeps, lights etc. However, the engine revved in response to short bursts on the separate little throttle lever I tested when flushing it at home.
A Utube vid from etecownersgroup.com that showed likely cause as TCS mssg error from control cable slop/lag induced by coiling a too long cable, (as I have done).  I checked the cable linkage slop as per the vid, it was only little, say less than or max 1/4", not 3/8" or more, but the clearance between cam and the roller pin, at least 1/16", seems larger than the "air gap" described. TCS seems to operate freely via moving the rod from the cam.
Spoke to my local dealer & asked if their service testing 11 mths ago included "in gear" running that would have shown this problem. He said yes, it was water tank load tested, no throttle problem, great motor in as new condition, only 304 hrs usage. I asked about the cable length/coiling/lag diagnosis & he say coiling lag not likely cause as even new cables have that much slop, but mainly, that the response to the neutral throttle lever shows functioning linkage/TCS/EMM operation so most likely culprit is control box selector sensor switch fail. Have checked/compared linkage operation to both fwd & reverse full position. Throttle cam/roller-link rod movement/TCS rotation is same for both. The position for both is tight and not able to move the cam/rod & TCS rotation any further. Would a failed selector sensor switch cause a TCS mssg error to the EMM, despite full TCS rotation?
Any comments or other suggestions on this would be greatly appreciated pls.

Am not able to work, only have boat via Dad's will & good wife with limited income, so not want to buy & install new cables unnecessarily, then have to pay dealer to replace other stuff as well.
I don't have any electronic/computer diagnostic facilities to check for errors etc.
Ta. Nifty


__________________
Nrw
Nordmann

Registered:
Posts: 1,517
Reply with quote  #2 
Sounds like your neutral switch is sticking. Switch is located on lower starboard side of power head. Watch switch plunger for movement with helper shifting in and out of gear.

Remember to spin propeller to easily engage gear.

__________________
Nordmann.

Sign seen in a dentist's waiting room:
There is nothing the dentist can do, that the patient won't do!
steelhead

Avatar / Picture

Registered:
Posts: 4,085
Reply with quote  #3 
E. Service manual for free DL online to help you out.  Almost impossible to analyze and troubleshoot one of these E-TECs without one.

Wiring diagrams at end.

https://www.manualslib.com/products/Evinrude-E-Tec-E90dplsum-9983552.html

Post up your town or State area location, maybe there is a member near by with E. Diagnostics software that can help you out.
Nifty1

Registered:
Posts: 13
Reply with quote  #4 
Quote:
Originally Posted by Nordmann
Sounds like your neutral switch is sticking. Switch is located on lower starboard side of power head. Watch switch plunger for movement with helper shifting in and out of gear.

Remember to spin propeller to easily engage gear.

Thanks Nordmann. Will check it out when Australian sun rises.

__________________
Nrw
Nifty1

Registered:
Posts: 13
Reply with quote  #5 
Hmm. Not familiar with how this works. Hope tis is a reply.... Ta Nordmann.. Will check it out when Australian sun rises.
__________________
Nrw
Nifty1

Registered:
Posts: 13
Reply with quote  #6 
Hi steelhead. Thanks for your reply. I am in Australia, State Queensland, City Gold Coast, Suburb Palm Beach 4221.
__________________
Nrw
Nifty1

Registered:
Posts: 13
Reply with quote  #7 
Hi All, Many thanks for this forum,, Called local dealer and booked diagnostic check etc,,, = corrosion gunk on intake leaves/shaft caused sticking limiting throttle activation,, inspection also revealed, (thanks nordman), unexplainable neutral switch disconnection. No answer to how engine started and ran at all,, the reconnected switch showed failure to function so new one installed = it goes like a rocket on my 14' fbreglass, now "sport cabin", previously runabout boat,,, BUT ,,, sea testing proved boat remodel design mods failed with stbd imbalance list from stbd dual batteries, screen top 5" too high / standing at steering wheel, eye level too low for safe vision underway and control box lever too low for required floor height raise of standing position & screen haircut. My control cable looped installation works 100% effective, no lag problems.
Oh well,, back to the shed for mods of mods and a little rewiring / battery move to port!!! Will get fishing eventually!!! MUST be before December to April pelagic species runs!!!
Ta Nifty.

__________________
Nrw
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Disclaimer: Activities and modifications described or displayed on this message board and it's pages may be potentially dangerous. E-TEC Owners Group along with Barnacle Bills Marine does not endorse or make any claims to their safety or performance. Be sure a trained E-TEC service technician performs all your service work.