Bringing Evinrude E-TEC owners together.

Register New Posts
 
 
 


Reply
 
Author Comment
 
WallyJ

Registered: 09/02/09
Posts: 11
Reply with quote  #1 

I have a 90 etec. I use this motor a ton for trolling and this motor has gave me issues from day one. I kind of just looked past the issues as they got fixed . But now I have a four and a half year old motor that just shuts off all the time while trolling. I use a happy troller all the time I troll to slow me down and it works great!!! All summer this things been in the shop and BRP cant seem to figure the problem out with the techs trying to fix it. Just wondering if any one elese has had a problem Thanks for any info WallyJ

Huey

Moderator
Registered: 04/20/08
Posts: 8,328
Reply with quote  #2 
Hi Wally, sorry to hear this, but they can idle/troll all day when running as designed. Make sure she is propped right to see 5000-5200 at WOT, make sure she is running upto temp at low speed-an engine that runs cold is not good. Make sure you have the latest revision-96905. Of course make sure the basics are there and you have good compression, good fuel and I hope you have a water separating filter in the boat. Also it is not hard but you should check the high pressure fuel pump and make sure there is no debris blocking it-we had an I-3 here recently running rough and the pump intake was totally blocked and as were the injectors-again easy for a trained tech to check. If all passes you can try the trick of fitting the longer deflector pins and we have had good success using the latter style plugs, but only suggest to try these when all else is checked and confirmed as correct.

Let us know what or if any of the above has been done.

Cheers,

Huey.
Cheers
WallyJ

Registered: 09/02/09
Posts: 11
Reply with quote  #3 

All of these things have been done to this motor and it has been proped 3 times.BRP has it in there hands right now they called me today and they are trying to figure out what to do because they dont know what elese to do as of right now. I thank u for the info and I WELL KEEP U POSTED ON THE RESULTS. thanks for all the help wally j

koboss

Avatar / Picture

Gold Level Member 4-2010
Registered: 03/14/09
Posts: 308
Reply with quote  #4 
That sounds like what happens to me, i will be trolling and the motor will just up and shut off, and i havent turned the key or nothing, it happened 3 or 4 times and when i tell the tech's they look at me like i have been on a bender or am thinking this up, anyway of coarse nothing shows up on the emm like the no oil alarms that pop up arnt recorded either. now it hasnt done it since the spring so nock on wood.



__________________
2006 Stanley Mink, Dual Console, All welded 3/16 Alumminum, 1100lbs
2009 Evinrude 90 E-TEC, 320lbs 17" Viper & 15" rouge
I-Command Gauges, XD100 oil,Follow me on TWITTER @kobboss
Total weight:hull,fuel,driver,motor,gear. 1850lbs
Model 90DSLSE
S/N 05260370
BobT

Registered: 05/06/08
Posts: 76
Reply with quote  #5 
Quote:
Originally Posted by WallyJ

All of these things have been done to this motor and it has been proped 3 times.BRP has it in there hands right now they called me today and they are trying to figure out what to do because they dont know what elese to do as of right now. I thank u for the info and I WELL KEEP U POSTED ON THE RESULTS. thanks for all the help wally j



Any update???

__________________

• 2006 Maritime Skiff 1890 •
• 2006 90hp E-TEC •
Model #E90DSLSD
Ser #05132445
WallyJ

Registered: 09/02/09
Posts: 11
Reply with quote  #6 

NO real answers yet had it back in and no good news and now they are changing all three injectors and checking heads ill keep udating thanks wally j

WallyJ

Registered: 09/02/09
Posts: 11
Reply with quote  #7 
All three injectors have been replaced and the hole motor dang near replaced and now they took my heads off and noticed wave like scoreing on the cylinder and it seems that the cylinder is also cracked.  I have about 575 hrs on this 05 90 etec and it has been a problem since day one. I f i get a call monday saying i need a new power head i might just ?????  I havent used my boat 12 times all summer because of this problem since day one. Now the snow is hitting me in ???? and I want go catch some walters and I still cant go out. Wow thanks for listing to me complain and any help would be great.


                           Thanks Wally J
Huey

Moderator
Registered: 04/20/08
Posts: 8,328
Reply with quote  #8 
Hi Wally, as per previous post, what is your serial number and post a history report so that we can confrim WOT RPM and software versions.

Cheers,

Huey.
WallyJ

Registered: 09/02/09
Posts: 11
Reply with quote  #9 

Sounds like im getting a new power head at my expense!! Not to happy about this because ive had these problems for the last couple years . and now that my boat is out of warranty I get the 4000 dollar power head. Wow I hope this isnt some thing etec is going to have problems With in the feature. Good luck to u all hope no one elese has these problems.      Wally J 

Huey

Moderator
Registered: 04/20/08
Posts: 8,328
Reply with quote  #10 
Hi Wally, what is your serial number?

Cheers,

Huey.
csidave

Avatar / Picture

Gold Level Member 3-2010
Registered: 07/11/08
Posts: 104
Reply with quote  #11 
Huey, this was in his profile info:

Engine Serial Number 05097346  
Engine Model Number E90DSLSOC  


__________________
CsiDave
2008 Scarab Sport
Twin 250 E-Tec's
E250DPXSC 05199791
E250DCXSC 05209725
WallyJ

Registered: 09/02/09
Posts: 11
Reply with quote  #12 

Thanks for getting that for me I just got out of surgery sorry dint have time huey                Wally J

Huey

Moderator
Registered: 04/20/08
Posts: 8,328
Reply with quote  #13 
Hi, running that number yes you are out of warranty and had some minor fuel related warranty replacements like on board filter done years ago. I see the vap separator was done recently, why was that-did you get a bad dose of fuel and I also see where 1 injector was replaced under warranty only a month ago which is a bit strange if you say 3 were done and also being over 12 months out of warranty. I imagine you have a water separating filter installed in the boat and do not use ethanol fuel and if you have to I hope you use fuel conditioner.

I wonder if the new injector was installed correctly and the new co-efficient loaded into the EMM. Weird that an engine that has done many hours and is of this age to just fail for no reason and i would be thinking it is a fuel related issue.

Cheers,

Huey.


WallyJ

Registered: 09/02/09
Posts: 11
Reply with quote  #14 

There's alot more that they did in the last 3 weeks that is not on there yet and yes all the injectors have been replaced and I don't know what else I could have done to prevent this and if there is I would like to know because it's a pretty big hit on my wallet. Just can't stand the fact that this boat isn't that old and i'm nervous to see what's next in line. Thanks for all the help.                                            Wally J

Huey

Moderator
Registered: 04/20/08
Posts: 8,328
Reply with quote  #15 
Hi, if it has been in the last three weeks then not sure why it would show on dealerport because your engine was out of warranty over 12 months ago. The 1 injector was replaced only on the 09/23 so about a month ago and that is on dealerport so are you sure they replaced three and were they all new and not sure why it would be covered under warranty only last month because your warranty expired almost 18 months ago, but there are two sides to every story. Get a history report and post here and were you propped to see 5000-5200, running XD-100 and set for that and reaching correct temps with no codes stored.

At the end of the day if you have lost confidence in the engine, your dealer or BRP best to cut your losses and get another outboard and i wish you all the best. If you rebuild this engine, which if only picked up slightly on one cylinder, it would cost about A$1500, even less for you over there, make sure they do it right. IF you have 3 new injectors make sure the EMM knows about it and they are installed correctly, make sure you are reaching 5200 at WOT and run good quality fuel and oil and it should last.

Cheers,

Huey.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Disclaimer: Activities and modifications described or displayed on this message board and it's pages may be potentially dangerous. E-TEC Owners Group along with Barnacle Bills Marine does not endorse or make any claims to their safety or performance. Be sure a trained E-TEC service technician performs all your service work.
Powered by Website Toolbox - Create a Website Forum Hosting, Guestbook Hosting, or Website Chat Room for your website.