Brought to you by Barnacle Bill's Marine Supply. (856) 785 9455

Register Latest Topics
 
 
 


Reply
  Author   Comment   Page 1 of 3      1   2   3   Next
Dansly56

Registered:
Posts: 15
Reply with quote  #1 
Hello I have a problem with my 2005 Evinrude 90hp etec. I took my boat out at a high elevation lake and it was giving me issues with the smell of gas at throttle and would not go over 10mph all 3 days I was there. The boat never shut off and ran but never over 10mph. The boat ran perfectly fine prior to taking it up and last time I used the boat and that was about 1 1/2 months ago. My prime bulb was not holding full and had to pump it every time I started my boat, or or could it be a fuel pump issue? My engine had the yearly maintenance done at a local shop back in April and only has 52hrs, it was put on the laptop and showed no codes, also the compression was 130 across. I called the mechanic that did the work and of coarse he wants me to bring it in but I wanted to ask you guys your thoughts on the issue before I take it in. Any advice will be greatly appreciated. Thanks
PhilH12

Registered:
Posts: 1,750
Reply with quote  #2 
The smell of gas surely suggests a fuel leak to me.  Not sure that the elevation itself would be a real cause.

Meanwhile, a source of fuel leakage could also be a source of air leaks into the fuel delivery.  #1- A potential fire happening  #2- Potentially running lean, which could destroy your motor.

I'd be finding that cause pretty quickly, before running it too much!

EDIT:  Did the boat sit with ethanol fuel for 1.5 months without fuel treatment?  That won't cause "fuel smell" itself, but may have started eating away at rubber hoses, etc.

Phil

__________________
Always check the Easy Stuff First!
20' Weeres fishing pontoon
90 HP E-Tec E90DPLSUM  05184332
Lake Tawakoni, TX - Catfish Capital of Texas
Dansly56

Registered:
Posts: 15
Reply with quote  #3 
It did sit with ethonal for 1.5 months but with some fuel treatment. The boat started up fine never shut off and ran great but would not go over 10mph when it usually it runs 28-32mph. I pulled the cowling and didn’t see any fuel leakage or signs of tears in the hoses it sounded good when at idle and running but just wouldn’t go over 10mph
rickmcd53

Registered:
Posts: 1,100
Reply with quote  #4 
Very hard to guess at causes with speed numbers instead of rpm numbers. S.A.F.E. mode on these engines limit speed to 1800 rpm. My 90 pushed my boat 7 mph at 1800.
Dansly56

Registered:
Posts: 15
Reply with quote  #5 
And what was the problem with your 90?
rickmcd53

Registered:
Posts: 1,100
Reply with quote  #6 
I did not have a problem with it. Was just suggesting that your 10 mph limit could be due to the engine being in safe mode.
Dansly56

Registered:
Posts: 15
Reply with quote  #7 
Quote:
Originally Posted by rickmcd53
I did not have a problem with it. Was just suggesting that your 10 mph limit could be due to the engine being in safe mode.

Oh ok
Crosbyman

Registered:
Posts: 347
Reply with quote  #8 
vst filter  clogged ??  no lights  on the tach ??   

btw my 2005  75hp sits 6 months a year with full  gas and  2+4D   never had ethanol issues …  my first VST filter change  last Spring… after 13 years  showed 3-4 dust like black specs  

 I seem to recall my safe  mode years ago for  code 38 's was...1200 rpm

__________________
ETEC 75 HP  2005  ser# 05107924  &  1966  9.5 hp  Sportwin 9622a 
rickmcd53

Registered:
Posts: 1,100
Reply with quote  #9 
You are correct, I confused the neutral rev limiter of about 1800rpm with the safe mode limiter of 1200rpm.
Dansly56

Registered:
Posts: 15
Reply with quote  #10 
So what causes safe mode,
Huey

Moderator
Registered:
Posts: 13,135
Reply with quote  #11 
A few things but instead of listing them and playing the 20 question game, you need to tell us what the RPM is when it does not reach top speed and best to post a edf and snap shot of when the engine does not reach WOT RPM. I am guessing you are back at sea level or not at altitude now so does the engine rev out properly now?
Dansly56

Registered:
Posts: 15
Reply with quote  #12 
I am back and once I take it out again I will let you known
Dansly56

Registered:
Posts: 15
Reply with quote  #13 
Found out my boat is in safe mode. Hopefully it’s nothing to bad and just a fuel line or fuel pump issue
steelhead

Avatar / Picture

Registered:
Posts: 2,848
Reply with quote  #14 
Do you have the Evinrude Service manual for your model# and the Evinrude Diagnostics software?
Dansly56

Registered:
Posts: 15
Reply with quote  #15 
Quote:
Originally Posted by steelhead
Do you have the Evinrude Service manual for your model# and the Evinrude Diagnostics software?


Unfortunately I don’t and the closet evinrude service shop is 2hrs away
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Disclaimer: Activities and modifications described or displayed on this message board and it's pages may be potentially dangerous. E-TEC Owners Group along with Barnacle Bills Marine does not endorse or make any claims to their safety or performance. Be sure a trained E-TEC service technician performs all your service work.